using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"label\W+(?:\w+\W+){1,60}?(?:.){0,}?(\<TAG1\>|\<TAG2\>)(?:.){0,}?\W+(?:\w+\W+){1,60}(?:.){0,}?(\<TAG2\>|\<TAG1\>)(?:.){0,}?";
string input = @"before label bla bla bla aaaa<TAG1>bbbb bla bla bla bla abcd<TAG2>efgh after";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}