import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "label\\W+(?:\\w+\\W+){1,60}?(?:.){0,}?(\\<TAG1\\>|\\<TAG2\\>)(?:.){0,}?\\W+(?:\\w+\\W+){1,60}(?:.){0,}?(\\<TAG2\\>|\\<TAG1\\>)(?:.){0,}?";
final String string = "before label bla bla bla aaaa<TAG1>bbbb bla bla bla bla abcd<TAG2>efgh after";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}