re = /label\W+(?:\w+\W+){1,60}?(?:.){0,}?(\<TAG1\>|\<TAG2\>)(?:.){0,}?\W+(?:\w+\W+){1,60}(?:.){0,}?(\<TAG2\>|\<TAG1\>)(?:.){0,}?/
str = 'before label bla bla bla aaaa<TAG1>bbbb bla bla bla bla abcd<TAG2>efgh after'
# Print the match result
str.match(re) do |match|
puts match.to_s
end