#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?is)<!ENTITY\s[a-z0-9]*\s"(&[a-zA-Z0-9]+;){4,}">(?:.*?<!ENTITY\s[a-z0-9]*\s"(&[a-zA-Z0-9]+;){4,}">){4,}"
Local $sString = "<!DOCTYPE data [" & @CRLF & _
"<!ENTITY a0 "dos" >" & @CRLF & _
"<!ENTITY a1 "&a0;&a0;&a0;&a0;">" & @CRLF & _
"<!ENTITY a2 "&a1;&a1;&a1;&a1;&a1;&a1;">" & @CRLF & _
"<!ENTITY a1 "&a2;&a2;&a2;&a2;&a2;&a2;">" & @CRLF & _
"test" & @CRLF & _
"<!ENTITY a1 "&a2;&a2;&a2;&ertertert;&a2;&a2;">" & @CRLF & _
"<!ENTITY a1 "&a2;&a2;&a2;&ertertert;&a2;&a2;">" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"<!ENTITY a1 "&a2;&a2;&a2;&a2;&a2;&a2;">" & @CRLF & _
"d" & @CRLF & _
"dd" & @CRLF & _
"" & @CRLF & _
"<html abc>" & @CRLF & _
"a" & @CRLF & _
"" & @CRLF & _
"<!ENTITY a2 "&a3;&a3;&a3;&a3;&a3;">" & @CRLF & _
"<!ENTITY a1 "&a0;&a0;&a0;&a0;&d5;">" & @CRLF & _
"]>" & @CRLF & _
"<data>&a2;</data>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")