// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?is)<!ENTITY\s[a-z0-9]*\s"(&[a-zA-Z0-9]+;){4,}">(?:.*?<!ENTITY\s[a-z0-9]*\s"(&[a-zA-Z0-9]+;){4,}">){4,}"#).unwrap();
let string = "<!DOCTYPE data [
<!ENTITY a0 \"dos\" >
<!ENTITY a1 \"&a0;&a0;&a0;&a0;\">
<!ENTITY a2 \"&a1;&a1;&a1;&a1;&a1;&a1;\">
<!ENTITY a1 \"&a2;&a2;&a2;&a2;&a2;&a2;\">
test
<!ENTITY a1 \"&a2;&a2;&a2;&ertertert;&a2;&a2;\">
<!ENTITY a1 \"&a2;&a2;&a2;&ertertert;&a2;&a2;\">
<!ENTITY a1 \"&a2;&a2;&a2;&a2;&a2;&a2;\">
d
dd
<html abc>
a
<!ENTITY a2 \"&a3;&a3;&a3;&a3;&a3;\">
<!ENTITY a1 \"&a0;&a0;&a0;&a0;&d5;\">
]>
<data>&a2;</data>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}