using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<!ENTITY\s[a-z0-9]*\s""(&[a-zA-Z0-9]+;){4,}"">(?:.*?<!ENTITY\s[a-z0-9]*\s""(&[a-zA-Z0-9]+;){4,}"">){4,}";
string input = @"<!DOCTYPE data [
<!ENTITY a0 ""dos"" >
<!ENTITY a1 ""&a0;&a0;&a0;&a0;"">
<!ENTITY a2 ""&a1;&a1;&a1;&a1;&a1;&a1;"">
<!ENTITY a1 ""&a2;&a2;&a2;&a2;&a2;&a2;"">
test
<!ENTITY a1 ""&a2;&a2;&a2;&ertertert;&a2;&a2;"">
<!ENTITY a1 ""&a2;&a2;&a2;&ertertert;&a2;&a2;"">
<!ENTITY a1 ""&a2;&a2;&a2;&a2;&a2;&a2;"">
d
dd
<html abc>
a
<!ENTITY a2 ""&a3;&a3;&a3;&a3;&a3;"">
<!ENTITY a1 ""&a0;&a0;&a0;&a0;&d5;"">
]>
<data>&a2;</data>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Singleline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}