# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<!ENTITY\s[a-z0-9]*\s\"(&[a-zA-Z0-9]+;){4,}\">(?:.*?<!ENTITY\s[a-z0-9]*\s\"(&[a-zA-Z0-9]+;){4,}\">){4,}"
test_str = ("<!DOCTYPE data [\n"
"<!ENTITY a0 \"dos\" >\n"
"<!ENTITY a1 \"&a0;&a0;&a0;&a0;\">\n"
"<!ENTITY a2 \"&a1;&a1;&a1;&a1;&a1;&a1;\">\n"
"<!ENTITY a1 \"&a2;&a2;&a2;&a2;&a2;&a2;\">\n"
"test\n"
"<!ENTITY a1 \"&a2;&a2;&a2;&ertertert;&a2;&a2;\">\n"
"<!ENTITY a1 \"&a2;&a2;&a2;&ertertert;&a2;&a2;\">\n\n\n"
"<!ENTITY a1 \"&a2;&a2;&a2;&a2;&a2;&a2;\">\n"
"d\n"
"dd\n\n"
"<html abc>\n"
"a\n\n"
"<!ENTITY a2 \"&a3;&a3;&a3;&a3;&a3;\">\n"
"<!ENTITY a1 \"&a0;&a0;&a0;&a0;&d5;\">\n"
"]>\n"
"<data>&a2;</data>")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.