#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)Kwl\s?(\w+)\(\)"
Local $sString = "Kwl ThisString()" & @CRLF & _
"" & @CRLF & _
"Kwl String_2()" & @CRLF & _
"" & @CRLF & _
"kwl string_3_as_well()" & @CRLF & _
"" & @CRLF & _
"kwl maybethisverylongstringaswell()"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")