// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)Kwl\s?(\w+)\(\)").unwrap();
let string = "Kwl ThisString()
Kwl String_2()
kwl string_3_as_well()
kwl maybethisverylongstringaswell()";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}