$re = '/Kwl\s?(\w+)\(\)/mi';
$str = 'Kwl ThisString()
Kwl String_2()
kwl string_3_as_well()
kwl maybethisverylongstringaswell()';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);