using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"Kwl\s?(\w+)\(\)";
string input = @"Kwl ThisString()
Kwl String_2()
kwl string_3_as_well()
kwl maybethisverylongstringaswell()";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}