package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)((https?:\/\/)?((www|\w\w)\.)?linkedin\.com\/)((([\w]{2,3})?)|([^\/]+\/(([\w|\d-&#?=])+\/?){1,}))$`)
var str = `in.linkedin.com/pub/first-second/05/25/86
in.linkedin.com/pub/first-second/1/638/7a1
http://uk.linkedin.com/pub/first-second/1/1b3/b45/
http://in.linkedin.com/pub/first-second/hfk/uty
http://www.linkedin.com/in/aname/
http://linkedin.com/in/name
http://in.linkedin.com/in/name
http://in.linkedin.com/in/name/
in.linkedin.com/in/name/
https://www.linkedin.com/profile/view?id=AAIAABgM9d4ymiX9Dy4yXkQq9i1W01JsbMXp8lM&trk=nav_responsive_tab_profile
www.myweb.com?id=12&value=val
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}