import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((https?:\\/\\/)?((www|\\w\\w)\\.)?linkedin\\.com\\/)((([\\w]{2,3})?)|([^\\/]+\\/(([\\w|\\d-&#?=])+\\/?){1,}))$";
final String string = "in.linkedin.com/pub/first-second/05/25/86\n"
+ "in.linkedin.com/pub/first-second/1/638/7a1\n"
+ "http://uk.linkedin.com/pub/first-second/1/1b3/b45/\n"
+ "http://in.linkedin.com/pub/first-second/hfk/uty\n"
+ "http://www.linkedin.com/in/aname/\n"
+ "http://linkedin.com/in/name\n"
+ "http://in.linkedin.com/in/name\n"
+ "http://in.linkedin.com/in/name/\n"
+ "in.linkedin.com/in/name/\n"
+ "https://www.linkedin.com/profile/view?id=AAIAABgM9d4ymiX9Dy4yXkQq9i1W01JsbMXp8lM&trk=nav_responsive_tab_profile\n"
+ "www.myweb.com?id=12&value=val\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}