using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\.(*SKIP)(*F)|(\${(?>[^$}\\]+|\\.|(?1))*})";
string input = @"${FOO=BAR}
${FOO=${BAR=BAZ}}
But also handle inputs like this:
${FOO=\${BAR=BAZ}}
${FOO={${BAR=BAZ}}";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}