re = /\\.(*SKIP)(*F)|(\${(?>[^$}\\]+|\\.|(?1))*})/
str = '${FOO=BAR}
${FOO=${BAR=BAZ}}
But also handle inputs like this:
${FOO=\\${BAR=BAZ}}
${FOO={${BAR=BAZ}}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end