$re = '/\\\\.(*SKIP)(*F)|(\${(?>[^$}\\\\]+|\\\\.|(?1))*})/';
$str = '${FOO=BAR}
${FOO=${BAR=BAZ}}
But also handle inputs like this:
${FOO=\\${BAR=BAZ}}
${FOO={${BAR=BAZ}}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);