import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\\\.(*SKIP)(*F)|(\\$\\{(?>[^$\\}\\\\]+|\\\\.|(?1))*\\})";
final String string = "${FOO=BAR}\n"
+ "${FOO=${BAR=BAZ}}\n\n"
+ "But also handle inputs like this:\n\n"
+ "${FOO=\\${BAR=BAZ}}\n"
+ "${FOO={${BAR=BAZ}}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}