package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`{(?<token>{?[^}]+}?)}`)
var str = `{tokenTwo}_{tokenThree} or {tokenOne}{tokenTwo}
Some text {{someToken}} other text
Some text {someToken} other text
Some text {{someOtherToken}} other text {tokenTwo} more {tokenThree} text {lastToken}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}