re = /{(?<token>{?[^}]+}?)}/
str = '{tokenTwo}_{tokenThree} or {tokenOne}{tokenTwo}
Some text {{someToken}} other text
Some text {someToken} other text
Some text {{someOtherToken}} other text {tokenTwo} more {tokenThree} text {lastToken}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end