import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]+)(?:')";
final String string = "=if(D3<>\"\",if(iferror(regexmatch(D3,\"([0-9]+)(?:')\"),false)=true,REGEXEXTRACT(D3,\"([0-9]+)(?:')\")*12+REGEXEXTRACT(D3,\"([0-9]+)(?:\"&char(34)&\")\"),D3*12),\"\")";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}