// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]+)(?:')").unwrap();
let string = "=if(D3<>\"\",if(iferror(regexmatch(D3,\"([0-9]+)(?:')\"),false)=true,REGEXEXTRACT(D3,\"([0-9]+)(?:')\")*12+REGEXEXTRACT(D3,\"([0-9]+)(?:\"&char(34)&\")\"),D3*12),\"\")";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}