re = /([0-9]+)(?:')/m
str = '=if(D3<>"",if(iferror(regexmatch(D3,"([0-9]+)(?:\')"),false)=true,REGEXEXTRACT(D3,"([0-9]+)(?:\')")*12+REGEXEXTRACT(D3,"([0-9]+)(?:"&char(34)&")"),D3*12),"")'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end