using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"caused by: +([^:]+): +(.+)";
string input = @"caused by: System.StringException: Invalid id: 3285673465734";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}