re = /caused by: +([^:]+): +(.+)/
str = 'caused by: System.StringException: Invalid id: 3285673465734'
# Print the match result
str.match(re) do |match|
puts match.to_s
end