$re = '/caused by: +([^:]+): +(.+)/';
$str = 'caused by: System.StringException: Invalid id: 3285673465734';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);