package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`caused by: +([^:]+): +(.+)`)
var str = `caused by: System.StringException: Invalid id: 3285673465734`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}