# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\<h3 id=\"title\" class=\"mb-0 mt-0\"\>)(\<\?php echo L10n::icon\(')(.*?)('\); \?>)(\<\?php echo L10n::message\('label.)(.*?)(', )(L10n::label\()(.*?)(\); \?>)(\<\/h3>)"
test_str = ("<h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('camera'); ?><?php echo L10n::message('label.add', L10n::label('camera')); ?></h3>\n"
" <h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('bookmark'); ?><?php echo L10n::message('label.add', L10n::label('bookmark')); ?></h3>\n"
"<h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('dashboard'); ?><?php echo L10n::message('label.add', L10n::label('dashboard')); ?></h3>\n"
"<h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('dashboard'); ?><?php echo L10n::message('label.edit', L10n::label('dashboard')); ?></h3>")
subst = "$1$2$3$4<?php echo L10n::label($7)$8$9"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.