// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(\<h3 id=\"title\" class=\"mb-0 mt-0\"\>)(\<\?php echo L10n::icon\(')(.*?)('\); \?>)(\<\?php echo L10n::message\('label.)(.*?)(', )(L10n::label\()(.*?)(\); \?>)(\<\/h3>)"#).unwrap();
let string = "<h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('camera'); ?><?php echo L10n::message('label.add', L10n::label('camera')); ?></h3>
<h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('bookmark'); ?><?php echo L10n::message('label.add', L10n::label('bookmark')); ?></h3>
<h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('dashboard'); ?><?php echo L10n::message('label.add', L10n::label('dashboard')); ?></h3>
<h3 id=\"title\" class=\"mb-0 mt-0\"><?php echo L10n::icon('dashboard'); ?><?php echo L10n::message('label.edit', L10n::label('dashboard')); ?></h3>";
let substitution = "$1$2$3$4<?php echo L10n::label($7)$8$9";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}