using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[.!?])(?!$|[.!?])";
string substitution = @"\n";
string input = @"hello1?hello2????????";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}