use strict;
my $str = 'hello1?hello2????????';
my $regex = qr/(?<=[.!?])(?!$|[.!?])/p;
my $subst = '\\n';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";