re = /(?<=[.!?])(?!$|[.!?])/
str = 'hello1?hello2????????'
subst = '\\n'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result