using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\/my\/interesting\/path\/(?![0-9]*$)(\b[0-9A-Z]{11}\b)";
string input = @"http://myapp:8080/my/interesting/path/ABCDEF12345";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}