$re = '/\/my\/interesting\/path\/(?![0-9]*$)(\b[0-9A-Z]{11}\b)/m';
$str = 'http://myapp:8080/my/interesting/path/ABCDEF12345';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);