const regex = /\/my\/interesting\/path\/(?![0-9]*$)(\b[0-9A-Z]{11}\b)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\\/my\\\/interesting\\\/path\\\/(?![0-9]*$)(\\b[0-9A-Z]{11}\\b)', 'gm')
const str = `http://myapp:8080/my/interesting/path/ABCDEF12345`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}