# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=\s\d)(?=\s)/,/gm;t' <<< "3 I am going at 5pm to type 3.3 and the 9 later"