import re
regex = re.compile(r"(?<=\s\d)(?=\s)", flags=re.MULTILINE)
test_str = "3 I am going at 5pm to type 3.3 and the 9 later"
subst = ","
result = regex.sub(subst, test_str)
if result:
print(result)