re = /(?<=\s\d)(?=\s)/m
str = '3 I am going at 5pm to type 3.3 and the 9 later'
subst = ','
result = str.gsub(re, subst)
# Print the result of the substitution
puts result