use strict;
my $str = '3 I am going at 5pm to type 3.3 and the 9 later';
my $regex = qr/(?<=\s\d)(?=\s)/mp;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";