#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)hello\.this_is\(([\047"])\K((?!\1).|\\.)*\1(?=\))"
Local $sString = "hello.this_is("bla bla bla")" & @CRLF & _
"some random text" & @CRLF & _
"hello.this_is('hello \'hello')" & @CRLF & _
"other stuff" & @CRLF & _
"hello.this_is(XhelloX)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")