import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "hello\\.this_is\\(([\\047\"])\\K((?!\\1).|\\\\.)*\\1(?=\\))";
final String string = "hello.this_is(\"bla bla bla\")\n"
+ "some random text\n"
+ "hello.this_is('hello \\'hello')\n"
+ "other stuff\n"
+ "hello.this_is(XhelloX)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}