$re = '/hello\.this_is\(([\047"])\K((?!\1).|\\\\.)*\1(?=\))/m';
$str = 'hello.this_is("bla bla bla")
some random text
hello.this_is(\'hello \\\'hello\')
other stuff
hello.this_is(XhelloX)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);