use strict;
my $str = 'hello.this_is("bla bla bla")
some random text
hello.this_is(\'hello \\\'hello\')
other stuff
hello.this_is(XhelloX)';
my $regex = qr/hello\.this_is\(([\047"])\K((?!\1).|\\.)*\1(?=\))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}