import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^/$|^(?:/(home|about|badge))?/((?:badge|abc)\\.png|[a-zA-Z0-9]*)$";
final String string = "/\n"
+ "/home/\n"
+ "/about/\n"
+ "/home/13jia0\n"
+ "/about/1jnmjan\n"
+ "/badge.png\n"
+ "/abc.png\n"
+ "/about/global\n"
+ "/about/abc.png\n"
+ "/badge.png\n\n"
+ "/nope/\n"
+ "/invalid.png\n"
+ "/test/test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}