re = /^\/$|^(?:\/(home|about|badge))?\/((?:badge|abc)\.png|[a-zA-Z0-9]*)$/m
str = '/
/home/
/about/
/home/13jia0
/about/1jnmjan
/badge.png
/abc.png
/about/global
/about/abc.png
/badge.png
/nope/
/invalid.png
/test/test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end