const regex = new RegExp('^/$|^(?:/(home|about|badge))?/((?:badge|abc)\\.png|[a-zA-Z0-9]*)$', 'gm')
const str = `/
/home/
/about/
/home/13jia0
/about/1jnmjan
/badge.png
/abc.png
/about/global
/about/abc.png
/badge.png
/nope/
/invalid.png
/test/test`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}