import re
regex = re.compile(r"^/$|^(?:/(home|about|badge))?/((?:badge|abc)\.png|[a-zA-Z0-9]*)$", flags=re.MULTILINE)
test_str = ("/\n"
"/home/\n"
"/about/\n"
"/home/13jia0\n"
"/about/1jnmjan\n"
"/badge.png\n"
"/abc.png\n"
"/about/global\n"
"/about/abc.png\n"
"/badge.png\n\n"
"/nope/\n"
"/invalid.png\n"
"/test/test")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")