package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)foreach\((?<loop>[a-zA-Z0-9-. _\(\)]+)\n{(?<code1>[a-zA-Z0-9-. _\;\n(\){}]+)await(?<code2>[a-zA-Z0-9-. _\;\n(\){}]+)}`)
var str = `var a = 10;
foreach(var item in items)
{
if(a)
{
Somecode();
}
await Process(Item);
if(a)
{
Somecode();
}
}
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}