use strict;
my $str = 'var a = 10;
foreach(var item in items)
{
if(a)
{
Somecode();
}
await Process(Item);
if(a)
{
Somecode();
}
}
';
my $regex = qr/foreach\((?<loop>[a-zA-Z0-9-. _\(\)]+)\n{(?<code1>[a-zA-Z0-9-. _\;\n(\){}]+)await(?<code2>[a-zA-Z0-9-. _\;\n(\){}]+)}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}