import Foundation
let pattern = #"foreach\((?<loop>[a-zA-Z0-9-. _\(\)]+)\n{(?<code1>[a-zA-Z0-9-. _\;\n(\){}]+)await(?<code2>[a-zA-Z0-9-. _\;\n(\){}]+)}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
var a = 10;
foreach(var item in items)
{
if(a)
{
Somecode();
}
await Process(Item);
if(a)
{
Somecode();
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)