re = /foreach\((?<loop>[a-zA-Z0-9-. _\(\)]+)\n{(?<code1>[a-zA-Z0-9-. _\;\n(\){}]+)await(?<code2>[a-zA-Z0-9-. _\;\n(\){}]+)}/m
str = 'var a = 10;
foreach(var item in items)
{
if(a)
{
Somecode();
}
await Process(Item);
if(a)
{
Somecode();
}
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end